Player Errors

Incident Report for Vimeo OTT

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 12:54 EDT

Identified

The Vimeo Player is experiencing issues, also impacting the OTT product. We're working with the Vimeo platform team to resolve the issue.
Posted Apr 14, 2026 - 12:38 EDT
This incident affected: Vimeo OTT Embeds.