Thumbnails Not Loading

Incident Report for Vimeo OTT

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 15:24 EDT

Identified

Thumbnails are failing to load or loading slower than usual in some cases. The root cause has been identified in a widespread outage on the Google Cloud US infrastructure.
We are monitoring the impact and working on a mitigation while the root cause is fixed by the provider.
Posted Sep 01, 2026 - 14:05 EDT
This incident affected: Vimeo OTT Platform and Branded Apps.