Chromecast not available

Incident Report for Vimeo OTT

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 13:18 EDT

Monitoring

Casting functionality has been restored.
Posted Oct 09, 2025 - 12:05 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 09, 2025 - 10:45 EDT

Investigating

We are currently investigating an issue with Chromecast functionality. Most users will not be able to cast from branded applications.
Posted Oct 09, 2025 - 10:40 EDT
This incident affected: Branded Apps.