Continue watching and playback progress not working properly

Incident Report for Vimeo OTT

Resolved

This incident has been resolved.
Posted Sep 27, 2025 - 22:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2025 - 15:09 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 25, 2025 - 17:46 EDT

Update

We have identified the issue and working on a fix.
Posted Sep 25, 2025 - 17:46 EDT

Investigating

We're currently investigating an issue where the "Continue Watching" feature is not updating user's progress. This may cause videos to not resume where you left off and also not show the recently watched videos on the continue watching row. Our team is actively working to resolve this as quickly as possible. We'll post an update as soon as we have more information.
Posted Sep 24, 2025 - 17:00 EDT
This incident affected: Vimeo OTT Platform and Branded Apps.