Issue with Video Playback
Incident Report for Vimeo OTT
Resolved
This issue is now resolved. Thank you for your patience.
Posted Apr 23, 2024 - 11:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2024 - 10:46 EDT
Investigating
We have identified issues with video playback. We are investigating and will update you here when we have more information.
Posted Apr 23, 2024 - 10:40 EDT
This incident affected: Vimeo OTT Platform, Vimeo OTT Embeds, and Branded Apps.