OTT Live Events Outage
Incident Report for Vimeo OTT
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 15:05 EST
Investigating
We are currently investigating an issue with OTT Live. At this time there may be issues starting live events.
Posted Feb 08, 2024 - 13:19 EST
This incident affected: Vimeo OTT Platform.