Promo codes cannot be applied on checkout page

Incident Report for Vimeo OTT

Resolved

The fix we released resolved the issue. Promo codes are working on the checkout page again.
Posted May 30, 2025 - 23:03 EDT

Monitoring

A fix has been released and we are monitoring the results.
Posted May 30, 2025 - 22:55 EDT

Identified

We've identified the root of the issue and working on implementing a fix.
Posted May 30, 2025 - 18:12 EDT
This incident affected: Vimeo OTT Platform.