OTT Maitenance Window - April 10, 2025

Scheduled for Apr 10, 05:30 - 06:00 EDT

Update

We will be undergoing routine database maintenance during this time. While we expect only a short period of downtime across apps, the web, and admin pages, we will do our best to minimize it.
Posted Apr 03, 2025 - 16:42 EDT

Scheduled

We will be undergoing routine database maintenance during this time. While we expect only a short period of downtime across apps, the web, and admin pages, we will do our best to minimize it.
Posted Apr 03, 2025 - 16:42 EDT
This scheduled maintenance affects: Vimeo OTT Platform and Branded Apps.