Issues loading OTT content
Incident Report for Vimeo OTT
Resolved
This issue is now resolved. Thank you for your patience.
Posted Feb 06, 2024 - 12:22 EST
Monitoring
There was an issue loading Vimeo OTT content on the web and in apps. A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2024 - 11:22 EST
This incident affected: Vimeo OTT Platform and Branded Apps.