DRM playback issues on Android and iOS

Incident Report for Vimeo OTT

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 10:41 EDT

Investigating

We are currently investigating this issue.
Posted Jun 10, 2025 - 07:18 EDT