Issues with data in Subscriber & Viewership Report

Incident Report for Vimeo OTT

Update

We have identified a decline in available data in the Subscribers Report after March 28, 2025 and will investigate that along with the Viewership Report data discrepancies. We will continue to provide updates as we investigate the issue.
Posted Apr 01, 2025 - 14:57 EDT

Update

The issue with Subscribers Report data has been resolved.

We are still investigating an issue with data in the Viewership report. We will update you here when we have more information.
Posted Mar 28, 2025 - 17:33 EDT

Investigating

We have identified issues with a decline in available data in the Subscribers & Viewership Reports after March 24, 2025. We are investigating and will update you here when we have more information.
Posted Mar 28, 2025 - 14:56 EDT
This incident affects: Vimeo OTT Platform.